Algobox et algorithmes avec des exercices.

algobox

Initiation à l’algorithme avec le logiciel Algobox .

Algobox est un logiciel pédagogique d’initiation à l’algorithmique simple d’emploi.

A l’aide d’un mini-langage algorithmique en français et d’une interface simple, ce logiciel permet de concevoir des mini programmes et de tester des algorithmes simples, que l’on peut rencontrer dans l’enseignement des mathématiques au secondaire (seconde, première et terminale).

Un algorithme est un programme contenant une suite d’actions permettant d’arriver è un résultat en un nombre fini d’étapes.

Le mot algorithme vient du mathématicien arabo-musulman Al-Khawarizmi, surnommé le père de l’algèbre . Le domaine qui étudie les algorithmes est appelé l’algorithmique.

Certaines épreuves du baccalauréat S de mathématiques font intervenir des algorithmes créés par Algobox.

Le code des algorithmes se construit pas è pas è l’aide de commandes déjà prédéfinies dans le logiciel (lire, afficher, affecter, instruction si alors, boucles pour de è et tant que ) : cela permet au débutant de se concentrer principalement sur la logique algorithmique, la programmation et création de boucles plutôt que sur l’apprentissage d’une syntaxe complexe.

Une fois l’algorithme terminé, il suffit d’exécuter le programme afin de voir son rendu. AlgoBox et algorithmes permet également de comprendre des algorithmes prédéfinis.

Afin de pouvoir approcher les situations mathématiques diverses que l’on peut rencontrer au lycée,

Ce logiciel inclut aussi la possibilité d’utiliser une fonction numérique ainsi que de tracer des points et des segments dans un repère préalablement défini.

Exercices d’algorithmique : calculatrice, tableur et algobox.

Algorithme de résolution des équations du second degré.

Voici un algorithme de résolution de l’équation du second degré :

ax^2+bx+c\,(a\neq0)

Entrées :

Saisir a,b,c (a non nul)

Traitement :

D prend la valeur   b^2-4ac 

Afficher D

     Si D>0 alors

                  X prend la valeur \frac{-b-\sqrt{D}}{2a}

                 Y prend la valeur \frac{-b+\sqrt{D}}{2a}

                 Afficher X,Y

   FinSi

  Si D=0  alors

              X prend la valeur -\frac{b}{2a}

             Afficher X

  FinSi

  Si D<0 alors

                Afficher « Pas de solutions »

  FinSi

       

1. Coder cet algorithme dans un langage de programmation avec votre calculatrice ou algobox .

2. Exécuter le programme obtenu avec a=1, b= – 5 et c= 6.

Algorithme de dichotomie.

f est la fonction sur [0;1] par :

f(x)=x^3+2x-1.

1. Tracer la courbe représentative de f à l’écran de votre calculatrice.

2. On considère l’algorithme ci-dessous :

Initialisations :

a prend la valeur 0

b prend la valeur 1

Traitement :

Tant que b-a > 0,01

m prend la valeur \frac{a+b}{2}

Si f(m)>0 alors

b prend la valeur m

sinon

a prend la valeur m

FinSi

FinTantque

Sorties :

Afficher a,b

1. Expliquer le rôle de cet algorithme .

2. La condition b-a>0,01 qui gère la boucle peut-elle être modifiée ?Expliquer.

3.a. Traduire cet algorithme dans un langage de programmation avec algobox ou votre calculatrice.

b. Saisir le programme obtenu à la calculatrice ou à l’ordinateur.

c. Vérifier le fonctionnement du programme.

Simuler une expérience aléatoire.

Une urne contient 3 boules blanches et 2 boules noires.

On tire au hasard une boule de l’urne et on note sa couleur.

Le programme suivant, écrit avec le langage Algobox, réalise une simulation de cette expérience aléatoire.

Algorithme.

1. Expliquer le test réalise dans ce programme.

2. Finaliser ce programme afin qu’il corresponde à l’énoncé.

3.a. Saisir ce programme à l’ordinateur.

b. Vérifier le fonctionnement du programme.

Programmer une fonction.

Soit f est la fonction polynôme de degré 2, de forme canonique

f(x)=-2(x-3)^2+5.

On se propose d’écrire un programme qui calcule l’image par la fonction f

d’un nombre réel donné.

1. Calculer l’image pour x=0; x=3 .

2. Ecrire ce programme avec algobox et vérifier vos résultats.

Indication :

Algobox et programmation.

La racine de 7.

On considère l’algorithme ci-après .

1. Faire fonctionner cet algorithme : on pourra effectuer quatre itérations.

On notera les valeurs de a et b obtenues après chaque itération.

2. Quel est le rôle de cet algorithme ?

3. Construire le programme associé avec le tableur, la calculatrice ou algobox.

4. Indiquer l’encadrement donné par le programme .

Initialisations :

a prend la valeur 2.

b prend la valeur 3.

Traitement :

Tant que b-a>10^{-3}

m prend la valeur \frac{a+b}{2}

Si m^2<7 alors

a prend la valeur m

sinon

b prend la valeur m

FinSi

FinTantque

Sorties :

Afficher a,b .

Distance entre réels.

Ecrire un algorithme

qui lit deux nombres réels x et y et

qui affiche la distance entre ces deux nombres .

Les inéquations.

a. On considère l’inéquation 6x+7\geq\, 0 .

Résoudre cette inéquation en suivant pas à pas les instructions de l’algorithme suivant :

  1. Retrancher 7 dans les deux membres .
  2. Diviser par 6 les deux membres .
  3. Ecrire l’ensemble des solutions .

b. Ecrire un algorithme de résolution de l’inéquation :

5x+3<-x+6.

Comparer deux nombres.

Algorithme pour comparer (x+y)^2 et x^2+y^2 .

x et y désignent des réels.

1. On considère l’algorithme :

Entrées:

Saisir x,y

Traitement :

a prend la valeur (x+y)^2 .

b prend la valeur x^2+y^2.

Sortie :

Afficher a-b .

Questions :

a. Ecrire le programme correspondant avec la calculatrice .

b. Conjecturer la comparaison de a et b suivant les valeurs de x et y.

2. Démonstration :

a. Développer et réduire (x+y)^2-(x^2+y^2) .

b. En déduire la comparaison du carré de la somme de deux réels avec la somme de leurs carrés.

Définir une fonction.

Voici un algorithme :

1. Lire x ( xnombre non nul).

2. Donner à u la valeur x^2 .

3. Donner à y la valeur \frac{1}{u} .

Quelle est la fonction définie par cet algorithme ?

Comparer deux réels.

Un algorithme pour comparer deux réels :

Ecrire un algorithme qui lit un nombre non nul x et

qui affiche suivant les valeurs de x le plus grand des deux nombres x^2 et \frac{1}{x} .

Conjecture sur un algorithme.

Voici la copie d’écran du logiciel Algobox .

algorithme

1. Tester cet algorithme avec n = 4, puis n = 7.

2. Un élève a saisi n = – 3.Que se passe t’il pourquoi ?

3. Emettre une conjecture sur le résultat fourni par cet algorithme.

4. Démontrer algébriquement cette conjecture .

4.3/5 - (6 votes)

Télécharger nos applications gratuites avec tous les cours,exercices corrigés.

Application Mathovore sur Google Play Store.    Application Mathovore sur Apple Store.     Suivez-nous sur YouTube.

D'autres fiches similaires à algobox et algorithmes avec des exercices..

Des documents similaires à algobox et algorithmes avec des exercices. à télécharger ou à imprimer gratuitement en PDF avec tous les cours et exercices de maths du collège au lycée et post bac rédigés par des enseignants de l'éducation nationale.
Vérifiez si vous avez acquis le contenu des différentes leçons (définitions, propriétés et théorèmes) en vous exerçant sur des milliers de documents disponibles sur Mathovore et chacun de ces exercices dispose de son corrigé.

  • 61
    Les inéquations : cours de maths en 3ème en PDF.Les inéquations du premier degré à une inconnue dans un cours de maths en 3ème où nous verrons la définition d'une inéquation ainsi que les règle de résolution des inéquations mais également, la représentation de l'ensemble solution sur une droite graduée et l'étude de problèmes amenant à une inéquation. I.…
  • 60
    Théorème de Pythagore : cours de maths en 4ème.Le théorème de Pythagore avec un cours de maths en 4ème faisant intervenir la partie directe et réciproque du théorème ainsi que la racine carrée d'un nombre positif et l'interprétation géométrique du théorème de Pythagore dans cette leçon en quatrième. 0-Introduction : un peu d’histoire…. Point de vue historique :…
  • 59
    Cours de maths en licence L1,L2 et L3 et en maths sup et math spéCes cours en PDF à télécharger gratuitement s'adressent aux étudiants de la Licence de Sciences et Techniques et des élèves de classes préparatoires aux grandes écoles (maths sup et spé). Ce cours sont adressés, également, aux élèves des classes préparatoires aux écoles d'ingénieurs (math sup) qui y trouveront l'opportunité de…


Les dernières fiches mises à jour.

Voici les dernières ressources similaires à algobox et algorithmes avec des exercices. mis à jour sur Mathovore (des cours, exercices, des contrôles et autres), rédigées par notre équipe d'enseignants.

  1. Les probabilités conditionnelles : cours de maths en terminale en PDF.
  2. Triangle et quadrilatère : exercices de maths en 6ème corrigés en PDF.
  3. Nombres décimaux : exercices de maths en 6ème corrigés en PDF.
  4. Les 4 opérations avec l’addition, la soustraction, la multiplication et la division : cours de maths en 6ème
  5. Limites et asymptotes : cours de maths en 1ère à télécharger en PDF.

Inscription gratuite à Mathovore.  Mathovore c'est 2 566 960 cours et exercices de maths téléchargés en PDF.