Algorithme de résolution des équations du second degré avec algobox

algobox

Voici un algorithme de résolution de l'équation du second degré :

ax^2+bx+c\,(a\neq0)

Entrées :

Saisir a,b,c (a non nul)

Traitement :

D prend la valeur   b^2-4ac 

Afficher D

     Si D>0 alors

                  X prend la valeur \frac{-b-\sqrt{D}}{2a}

                 Y prend la valeur \frac{-b+\sqrt{D}}{2a}

                 Afficher X,Y

   FinSi

  Si D=0  alors

              X prend la valeur -\frac{b}{2a}

             Afficher X

  FinSi

  Si D<0 alors

                Afficher "Pas de solutions"

  FinSi

       

1. Coder cet algorithme dans un langage de programmation avec votre calculatrice ou algobox .

2. Exécuter le programme obtenu avec a=1, b= – 5 et c= 6.

 

3.7/5 - (6 votes)

Télécharger nos applications gratuites avec tous les cours,exercices corrigés.

Application Mathovore sur Google Play Store. Application Mathovore sur Apple Store.

D'autres fiches similaires à algorithme de résolution des équations du second degré avec algobox.

Mathovore vous permet de réviser en ligne et de progresser en mathématiques tout au long de l'année scolaire.
De nombreuses ressources destinées aux élèves désireux de combler leurs lacunes en maths et d'envisager une progression constante. Tous les cours en primaire, au collège, au lycée mais également, en maths supérieures et spéciales ainsi qu'en licence sont disponibles sur notre sites web de mathématiques.
Des documents similaires à algorithme de résolution des équations du second degré avec algobox à télécharger ou à imprimer gratuitement en PDF avec tous les cours de maths du collège au lycée et post bac rédigés par des enseignants de l'éducation nationale.
Vérifiez si vous avez acquis le contenu des différentes leçons (définition, propriétés, téhorèmpe) en vous exerçant sur des milliers d'exercices de maths disponibles sur Mathovore et chacun de ces exercices dispose de son corrigé.
En complément des cours et exercices sur le thème algorithme de résolution des équations du second degré avec algobox, les élèves de troisième pourront réviser le brevet de maths en ligne ainsi que pour les élèves de terminale pourront s'exercer sur les sujets corrigé du baccalauréat de maths en ligne.
  • 92
    Algorithme et distance entre réels : Algorithme avec algoboxEcrire un algorithme qui lit deux nombres réels x et y et qui affiche la distance entre ces deux nombres .
  • 91
    Programmer une fonction : Algorithme avec algoboxf est la fonction polynôme de degré 2, de forme canonique On se propose d'écrire un programme qui calcule l'image par la fonction f d'un nombre réel donné. 1. Calculer l'image pour x=0; x=3 . 2. Ecrire ce programme avec algobox et vérifier vos résultats.   Indication :
  • 91
    Algorithme de dichotomie : Algorithme avec algoboxf est la fonction sur [0;1] par :   1. Tracer la courbe représentative de f à l'écran de votre calculatrice. 2. On considère l'algorithme ci-dessous : Initialisations : a prend la valeur 0 b prend la valeur 1 Traitement : Tant que b-a > 0,01 m prend la valeur …
  • 91
    Algorithme et racine de 7 : Algorithme avec algoboxOn considère l'algorithme ci-après . 1. Faire fonctionner cet algorithme : on pourra effectuer quatre itérations. On notera les valeurs de a et b obtenues après chaque itération.   2. Quel est le rôle de cet algorithme ? 3. Construire le programme associé avec le tableur, la calculatrice ou algobox.…
  • 91
    Algorithme et inéquation : Algorithme avec algoboxa. On considère l'inéquation  . Résoudre cette inéquation en suivant pas à pas les instructions de l'algorithme suivant : - Retrancher 7 dans les deux membres . - Diviser par 6 les deux membres . - Ecrire l'ensemble des solutions .   b. Ecrire un algorithme de résolution de l'inéquation :…


Retrouvez nos cours de maths et exercices corrigés sur notre chaîne YouTube.

Inscription gratuite à Mathovore.  Mathovore c'est 2 098 772 cours et exercices de maths téléchargés en PDF et 170 072 membres.
Rejoignez-nous : inscription gratuite.

A propos de webmaster 686 Articles
Webmaster du site Mathovore.