Algorithme de dichotomie : Algorithme avec algobox

algobox

f est la fonction sur [0;1] par :

mathematiques

 

1. Tracer la courbe représentative de f à l’écran de votre calculatrice.

2. On considère l’algorithme ci-dessous :

Initialisations :

a prend la valeur 0

b prend la valeur 1

Traitement :

Tant que b-a > 0,01

m prend la valeur mathematiques

Si f(m)>0 alors

b prend la valeur m

sinon

a prend la valeur m

FinSi

FinTantque

 

Sorties :

Afficher a,b

 

1. Expliquer le rôle de cet algorithme .

2. La condition b-a>0,01 qui gère la boucle peut-elle être modifiée ?Expliquer.

3.a. Traduire cet algorithme dans un langage de programmation avec algobox ou votre calculatrice.

b. Saisir le programme obtenu à la calculatrice ou à l’ordinateur.

c. Vérifier le fonctionnement du programme.



Télécharger nos applications gratuites avec tous les cours,exercices corrigés Application Mathovore sur Google Play Store. Application Mathovore sur Apple Store.

.

D'autres fiches similaires à algorithme de dichotomie : Algorithme avec algobox.

Mathovore vous permet de réviser en ligne et de progresser en mathématiques tout au long de l'année scolaire.
De nombreuses ressources destinées aux élèves désireux de combler leurs lacunes en maths et d'envisager une progression constante. Tous les cours en primaire, au collège, au lycée mais également, en maths supérieures et spéciales ainsi qu'en licence sont disponibles sur notre sites web de mathématiques.
Des documents similaires à algorithme de dichotomie : Algorithme avec algobox à télécharger ou à imprimer gratuitement en PDF avec tous les cours de maths du collège au lycée et post bac rédigés par des enseignants de l'éducation nationale.
Vérifiez si vous avez acquis le contenu des différentes leçons (définition, propriétés, téhorèmpe) en vous exerçant sur des milliers d'exercices de maths disponibles sur Mathovore et chacun de ces exercices dispose de son corrigé.
En complément des cours et exercices sur le thème algorithme de dichotomie : Algorithme avec algobox, les élèves de troisième pourront réviser le brevet de maths en ligne ainsi que pour les élèves de terminale pourront s'exercer sur les sujets corrigé du baccalauréat de maths en ligne.
  • 93
    Algorithme et racine de 7 : Algorithme avec algoboxOn considère l'algorithme ci-après . 1. Faire fonctionner cet algorithme : on pourra effectuer quatre itérations. On notera les valeurs de a et b obtenues après chaque itération.   2. Quel est le rôle de cet algorithme ? 3. Construire le programme associé avec le tableur, la calculatrice ou algobox.…
    Tags: algorithme, prend, b, a, m, on, algobox, programme, cet, finsi
  • 91
    Algorithme pour comparer deux nombres : Algorithme avec algoboxAlgorithme pour comparer  et  .    et  désignent des réels. 1. On considère l'algorithme : Entrées: Saisir x,y Traitement :  prend la valeur  .  prend la valeur  Sortie : Afficher  .   Questions : a. Ecrire le programme correspondant avec la calculatrice . b. Conjecturer la comparaison de  et  suivant les valeurs de  et . 2. Démonstration : a.…
    Tags: algorithme, prend, a, b, calculatrice, programme, afficher, traitement, saisir, l'algorithme
  • 91
    Algorithme de résolution des équations du second degré : Algorithme avec algoboxVoici un algorithme de résolution de l'équation du second degré : Entrées : Saisir a,b,c (a non nul) Traitement : D prend la valeur     Afficher D      Si D>0 alors                   X prend la valeur           …
    Tags: algorithme, afficher, prend, finsi, a, algobox, c, b, obtenu, programme
  • 90
    Algorithme pour définir une fonction : Algorithme avec algoboxVoici un algorithme : 1. Lire  ( nombre non nul). 2. Donner à  la valeur  . 3. Donner à  la valeur  . Quelle est la fonction définie par cet algorithme ?
    Tags: algorithme, fonction, algobox, cet, cours, maths, ème
  • 89
    Algorithme et distance entre réels : Algorithme avec algoboxEcrire un algorithme qui lit deux nombres réels x et y et qui affiche la distance entre ces deux nombres .
    Tags: algorithme, algobox, cours, maths, ème

Les dernières fiches mises à jour

Voici les dernières ressources mis à jour sur Mathovore (des cours, exercices, des contrôles et autres), rédigées par notre équipe d'enseignants.

Retrouvez nos cours de maths et exercices corrigés sur notre chaîne YouTube.

Inscription gratuite à Mathovore.  Mathovore c'est 2 009 078 cours et exercices de maths téléchargés en PDF et 168 098 membres.
Rejoignez-nous : inscription gratuite.

A propos de webmaster 688 Articles
Webmaster du site Mathovore.

Soyez le premier à commenter