algobox

Algorithme de dichotomie : Algorithme avec algobox

f est la fonction sur [0;1] par :

f(x)=x^3+2x-1.

1. Tracer la courbe représentative de f à l’écran de votre calculatrice.

2. On considère l’algorithme ci-dessous :

Initialisations :

a prend la valeur 0

b prend la valeur 1

Traitement :

Tant que b-a > 0,01

m prend la valeur \frac{a+b}{2}

Si f(m)>0 alors

b prend la valeur m

sinon

a prend la valeur m

FinSi

FinTantque

Sorties :

Afficher a,b

1. Expliquer le rôle de cet algorithme .

2. La condition b-a>0,01 qui gère la boucle peut-elle être modifiée ?Expliquer.

3.a. Traduire cet algorithme dans un langage de programmation avec algobox ou votre calculatrice.

b. Saisir le programme obtenu à la calculatrice ou à l’ordinateur.

c. Vérifier le fonctionnement du programme.



Télécharger nos applications gratuites avec tous les cours,exercices corrigés Application Mathovore sur Google Play Store. Application Mathovore sur Apple Store.

.

Les dernières fiches mises à jour

Voici les dernières ressources mis à jour sur Mathovore (des cours, exercices, des contrôles et autres), rédigées par notre équipe d'enseignants.


D'autres documents similaires

Inscription gratuite à Mathovore.  Mathovore c'est 1 650 187 cours et exercices de maths téléchargés en PDF et 150 863 membres.
Rejoignez-nous : inscription gratuite.

vidéos maths youtube
Mathovore

GRATUIT
VOIR